Windows XP missing operating system error with RAID configuration


(Jason Khan) #1

I have been given a computer to repair by a French customer that has Windows XP Pro French version installed, and it has 2 SATA Drives configured for RAID Mirroring. Everytime you try to boot it simply gives the error message Missing Operating System. The drives are detected in the BIOS.



The important data on computer has not been backed up seperately (Typical!) and the customer is desperate not to lose their Data



I have not worked with many RAID configurations and wonder if anybody has any tips as to get this machine to boot



The computer is an NEC WA1310 Workstation, with an MSI MS-7295 motherboard.



I have changed the BIOS battery, checked all connections etc and everything appears OK



Any help would be appreciated



Thanks



Jason


(Nick Aurelius-Haddock) #2

Phil I have started using the 1TB drives from seagate. You can get them from Maplin for £60 which seems good value to me for peace of mind.

I would also comment that Dropbox has managed to save Helen after her laptop failed , so has been proven as a DR technology, so should not be discounted.

I don’t think you can have too many backups, just not enough ;-).

Nick


(Jason Khan) #3

Hello everyone and many thanks for your replies. I had to give up on this one in the end as I did not want to cause more damage to the system and make any possible data recovery impossible. I spent over 10 hours trying to mount the drives with no success. I have handed the computer back to the customer unrepaired, and let them decide whether it is cost effective to got to a specialist data recovery service. I have now been asked to provide a backup solution for all their existing computers, so all the hours worked has not all been in vain!!

My wife and I run a holiday home business www.maisonlairoux.com and a computer business
www.mlcomputers.fr providing service and support, website creation and holiday home marketing services to French and English customers in the Vendee and throughout France.

Many Thanks again

Jason


(Phil Benn) #4

Slightly off topic, but SATA drives don’t generally have jumpers or require jumper settings due to the type of bus. However some drives have a jumper to switch between SATA-1 and SATA-2, but that’s generally all.

It’s probably a bit late now for the customer, but I think this thread serves as a gentle reminder for all of us to ensure we maintain regular backups of our data, and that we TEST them regularly. I’ve worked with so many companies that have extensive backup and DR processes in place but have never tested a restore.

I’m currently looking at the Western Digital My Book LX 2TB as a backup destination for my iMac. http://amzn.to/9FHIrn


(Nick Aurelius-Haddock) #5

lol, I know your pain Keith, I once had to spend a day recovering a USB hard drive for a friend, it was not fun.

I used this util which is cross platform TestDisk.

Jason if this util can’t see anything on the drives, then I doubt there is anything there to find. If none of those OSes can even see a partition, then I’m afraid it will need a specialist bit recovery firm, who charge a fortune, so I would get your chap to do a cost/benefit for potentially lost data before moving on that one.


(Jason Khan) #6

Hi Nick.

I have taken both drives out and placed them into an SATA caddy. Neither mount at all either on MAC OSX, Windows, or Ubuntu.

I have a feeling that I am not the first person to have looked at this problem computer and have been pulled in at the last resort. I think someone may have tried to rebuid or cleared the RAID but in doing so has cleared both drives. I am going to contact the owner to find out more about the history of this unit a little more. I am wary of messing around with the drives any further just in case the customer needs to send them to a specialist recovery company.

Will let you know what happens next!!

Thanks again Jason


(Nick Aurelius-Haddock) #7

To be honest I would have a go at letting the RAID utility see if it can fix it first. It might only make sure that the data on both drives is the same, but it may well cure your problem. It’s probably worth doing some research on that util and finding out what it can and can’t do for you. As it’s Nvidia , there must be some documentation somewhere on the web.

After that, then taking the unit out and putting it in a caddy should be fine as long as you don’t write anything to the drive. I would use something like Ubuntu from a boot cd, and just mount the available partitions read only.

Nick


(Jason Khan) #8

Hello Nick. Thanks for your reply. There is an option during boot to press f10 to access the Nvidia RAID utility Mediashield which gives me options to repair, Clear etc. I have not touched any of this yet. Both drives appear in the BIOS and spin up.

Am I safe to remove a drive and place it in an SATA Caddy to try and read the data? This is what I would normally do ahead of a Windows repair / reinstall especially if the customer has not backed up!

Thanks Jason


(Nick Aurelius-Haddock) #9

I think one key question here, is this software RAID or Hardware raid? If the motherboard was used to create the mirror, then the BIOS should offer you some utils to check the state of the mirror.

If it is being managed by WIndows, then XP does have a rescue mode, and last know good when you boot of the CD which might get you too a state where you can at least boot in rescue mode.

As mirroring is basically just having a read/write copy drive, it is possible to break the mirror and just work on the one drive, but you would have to boot from the XP CD to carry out this operation. Have any of the drives potentially failed?

Nick


(Jason Khan) #10

Hello Keith

Thanks for your email. Yes I have tried booting with a Linux disk but the drives are not found.

Regards

Jason