Easy Peasy on EeePC


(Ian Gillis) #1

Greg Harvey kindly recommended Easy Peasy in a couple of threads recently. I downloaded it to my Windows PC (it took over an hour at 2 Mbps) and used the transfer utility to put a disk image on a flash drive.
I booted the EeePC from the flash drive and played with Ubuntu as a replacement for the existing Xandros. It was more user-friendly, setting up the WiFi for my network was a doddle and I particularly liked the “F11 maximising” of the browser area which works better than the original OS.
So I then installed it over the top of the existing OS.
Now all I have to do is give my better half a quick Ubuntu course!
Thanks Greg!
regards,
Ian

Site Web http://www.notrevieenfrance.net
Blog http://stecolombedevilleneuve.wordpress.com/


(Ian Gillis) #2

Adding Java to Easy Peasy on EeePC:

I found I couldn’t use my EeePC with its new Ubuntu OS to display Live Timing on the Formula 1 website since it doesn’t have the Java Runtime Environment installed.
The answer is to open the terminal facility and type this code:
sudo add-apt-repository "deb <a href="http://archive.canonical.com/" target="_blank">http://archive.canonical.com/</a> lucid partner" [return] (nothing much happens here!) sudo apt-get update
[return]

now you can install the Sun Java packages with the code:
$ sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
[return]

HTH!
regards,
Ian


(Ian Gillis) #3

Nick wrote “When you created the new user using the user administration app, did you go into the advanced settings and make sure they had access to the wireless/network settings?”

Hi Nick,
Yes I did, but later, when I found the new user didn’t have wifi access. As I said before, I think the Keyring Password is the nub of the problem, it gives access to individual site usernames and passwords and presumably to the wifi WEP code.
Not to worry, having only one user is OK, the iGoogle and Gmail usernames/passwords are sticky so won’t need to be changed too often, and having only one account simplifies the file system.
regards,
Ian


(Nick Aurelius-Haddock) #4

I think I know what your issue was Ian, and it’s not a problem, it’s part of the Linux security.

When you created the new user using the user administration app, did you go into the advanced settings and make sure they had access to the wireless/network settings? If not then you won’t see them, it is design that way. It’s to stop people having access to things you don’t want them too.

If you do that then you shouldn’t have an issue. Now I don’t use that distro per se, but I’m sure they use the Ubuntu tools which I use daily.

Maybe post a picture of the settings you have if you still have an issue.

Nick


(Ian Gillis) #5

I might have known that my pride was due for a fall!
To save Elle Dedans changing all the log-in passwords for GMail, iGoogle etc., I configured a new user called xine and set her up with an appropriately girly desktop wallpaper. I also set up a choice of user on start-up.
However Xine’s account didn’t bring up the WiFi connection and I tinkered for hours, ticking wifi in the user privileges, etc. and reading the help files.
Then I found that I had no WiFi on either ian or xine - at this point I gave up and deleted the xine account but the WiFi icon remained stubbornly absent from ian. I’ve a feeling the problem is to do with the Ubuntu Keyring Password, which I don’t fully understand but when it’s asked for I get WiFi afterwards.
At this point I gave up and re-loaded everything from the USB key - which meant I had to re-do all the customisation tweaks and reload the updates. Elle Dedans will have to master logging on to GMail all by herself, using my account.
To me this is typical of the sort of pickle the naive user can get into with Linux systems - and you don’t have to go very deep to unearth some very incomprehensible Unix expressions!
regards,
Linux User (failed)


(Nick Aurelius-Haddock) #6

Glad to see things are moving well for you two, it is such a shame so many of these great little devices came crippled with Xandros or XP, as they really don’t give you a great experience. I would also recommend installing Google Chrome as it works well on these small screens and offers a big speed improvement. It will work fine on this Ubuntu derivative system.

There is also another great system for netbooks Eeebuntu, which I used to work on, but have unfortunately not had the time lately. There is a new version on it’s way shortly.
Nick


(Kathryn Dobson) #7

TBH he’s just had a look and the layout is such an improvement that I think he’s pretty much sold on it so I can probably switch over tonight.


(Ian Gillis) #8

@Kathryn - unfortunately you lose things like Firefox bookmarks and add-ons and WEP/WPA keys as they’re not written to the flash drive - so OH might find it inconvenient unless you leave it switched on, so permanent installation becomes more and more appealing…
regards,
Ian


(Kathryn Dobson) #9

Aha - I’ve worked it out from your prompt Ian - I wasn’t getting an F12 option on start up, just F2 and pressing F12 did nothing. In the setup there is a box to enable to F12 boot manager - once this is enabled, I can choose. Thank you!! Now just the wifi to configure and I’ll give it to my OH to play on for a few days before installing properly.


(Ian Gillis) #10

@Kathryn - with the Asus I just tapped ESC while the boot screen is displayed and I got a list of things to boot from. The destructions say use F12 if the netbook is an Acer. Have you tried that?
regards,
Ian


(Kathryn Dobson) #11

Greg or Ian - could you give me a hand please. I’ve downloaded Easy Peasy and then downloaded the Windows unetbootin file (I have Windows on my desktop). I’ve run that and created my disc image onto an empty USB stick (FAT32 formatted) and now have the EP on the stick. I’ve entered the Set up Utility on the netbook and picked my USB HDD to boot from but it continues to boot from the installed Windows. I’ve F10 saved and exited but on re-entering the set up, the IDEO location is highlighted. What am I doing wrong?

Thanks!


(Greg Harvey) #12

Glad you like it! =)