Linux/Ubuntu and a few other things, in several parts


(Miles Barrington) #1

Hello folks (mostly Nick I suspect!)


Background:


About 8 months ago I bought a shiny laptop online in the UK. Within 7 weeks it was sent off for a new motherboard, then a new screen, then another motherboard, and was due to be sent off again. I Complained to the people I bought it from, they said “It’s not the same machine we sold you, the serial numbers will not match”. It was they who told me to get in touch with HP, which I did, HP Said, can’t do it, but international warranty, get in touch with HP France. Anyway to cut a long story short, 3 motherboards, 2 screens and a rapidly shortening warranty period remaining later, HP said they would give me a new one. Score one for HP Customer service, even in France on a UK bought machine.





So to my question.


It’s coming with AZERTY and French Windows, and I intend to wipe it and start again. The AZERTY I can cope with (apart from the full stop).


Nick, I’ve heard from some technically competent friends that drivers for the hardware are not easy to find, and doing a dual boot could be less than straightforward. So, great to have open source (I’m trying to wean myself on to GIMP and Open Office) but what can Ubuntu offer me that would make it worthwhile putting in the work to get Ubuntu in and running smoothly alongside Win 7? I know that’s a very general question, but I can’t think of anyone who is a bigger proponent of Ubuntu.


Cheers


Miles


(Bob Thompson) #2

I’ll be upgrading as soon as it appears. If it is better than 10.10 then it should be fantastic! 10.10 is very impressive as it is.


(Nick Aurelius-Haddock) #3

Well there is a new version out at the end of the month, with a new interface, and a lot of new features, so give that a go. I’ll post on the main page when it’s out.

Regards

Nick


(Miles Barrington) #4

Well, I went back to Windows sadly. There was just too much not working and flitting between the netbook (which is actually Annette’s) and the laptop was just not practical. Yesterday I tried again but alongside windows, and got exactly the same issues. One day I’ll be Ubuntu’d, but not quite yet…


(Nick Aurelius-Haddock) #5

Well, it’s using your internal router for it’s DNS, so it must be caching it. Those times look good.

With your VM networking, try using the bridge option as opposed to NAT. You don’t need to NAT your VM, as your router is already NATing your data out onto the internet.

Nick


(Miles Barrington) #6

Now trying to ‘see’ in to the home network from the VM, as some of the access info I use regularly is on another machine. Tried to set up the NAT according to the user guide, but nothing showing. Any suggestions?
Miles


(Miles Barrington) #7

Yet another 'interesting trait of my installation: When the screen sleeps and I have to sign back in to the laptop in general, the VM loses my keyboard. All hints and tip still being Gratefully recieved!
Below is the reporting as suggested. the second part was done at a moment that SFN refused to load…

; <<>> DiG 9.7.1-P2 <<>> www.redhat.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52139
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.redhat.com. IN A

;; ANSWER SECTION:
www.redhat.com. 1 IN CNAME www.redhat.com.edgekey.net.
www.redhat.com.edgekey.net. 17273 IN CNAME www.redhat.com.edgekey.net.globalredir.akadns.net.
www.redhat.com.edgekey.net.globalredir.akadns.net. 3206 IN CNAME e86.b.akamaiedge.net.
e86.b.akamaiedge.net. 20 IN A 2.18.96.112

;; Query time: 60 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Mon Apr 4 08:16:04 2011
;; MSG SIZE rcvd: 179

miles@miles-dv6:~$

when SFN was stalled…

miles@miles-dv6:~$ dig www.survivefrance.com

; <<>> DiG 9.7.1-P2 <<>> www.survivefrance.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9201
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.survivefrance.com. IN A

;; ANSWER SECTION:
www.survivefrance.com. 483 IN CNAME survivefrance.ning.com.
survivefrance.ning.com. 20619 IN A 8.6.19.68

;; Query time: 36 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Mon Apr 4 08:17:09 2011
;; MSG SIZE rcvd: 88


(Bob Toovey) #8

Just a thought Nick, could there be a problem/conflict between IP4/IP6 lookups? That can slow things down…

bob


(Miles Barrington) #9

Ok, Empathy set up on my facebook ID.
Another thing I’ve not managed is to get my CD drive recognised by the VM so I can install the other couple of windows packages I use. There’s a lot of things I need to do, add or change, but very much small steps at the moment…
Miles


(Nick Aurelius-Haddock) #10

That browser speed issue is definitely not right, it could be that your ISP’s DNS servers are playing up. You don’t need to install Gtalk, as it works in a browser when you are logged into gmail. You can also use the empathy IM tool you get with Ubuntu to communicate with gtalk if you prefer. Very easy to set up.

Hibernate can be an issue with certain hardware, so i would always recommend suspend or to power off.

Can you mail me via the forum the output from the following command from a command line

dig www.redhat.com

If you have a speed issue again, run this command for the site you want to visit, and see if it returns an (IP ADDRESS ), if it does, type that into the browser and see if you get to the site.

Nick


(Miles Barrington) #11

Thank you Bob
Just tried to install Inkscape, and it won’t let me… ‘untrusted source’ being the reason. I assume I have all admin rights in my maching but there’s no obvious way to override it. Any clues?


(Miles Barrington) #12

Still running with it. Still having the same issues, this morning’s trick is that IE in the VM is working fine, FF and Chrome are not loading anything.
I shut the lid over night to hibernate, this morning it was all lit up, the lights were all on, the fan had run all night but the screen just would not wake. Should I install Gtalk?
Miles


(Miles Barrington) #13

I’ve tried to update this a few times, I’m now back on the netbook…

VM is working again but no CD drive showing, do I need to share it to the VM?

Still lots of hardware not installed, lots to learn on the filesharing and I found some stuff about mapping a network drive… it’s all go!
Oh And browser speed is variable to say the least…


(Miles Barrington) #14

Browser speed is back, no idea what that was. Now the VM for windows keeps coming up with an error, after I installed the package it told me to… hmmm.


(Miles Barrington) #15

Thanks Nick

Before It goes too much further, I need to map a network drive on a directory ‘P’ in the windows machine. I’ve tried to do it as if it were win7 and there are no options to do it. If that’s the case I need to use a normal windows installation anyway.
I don’t have a proxy (not actually sure what one is but I’m fairly sure I don’t have one…) I’ve not tried opera, just FF and Chrome, and IE in the virtual machine when I was having trouble with the others…

I did all the UBUNTU updates and was told to restart so I did and as every time, it hung and I had to use the power button

I use Skype for IM, or occasionally a telephone!

It would be fantastic if you could connect and have a look, I need to get on with some work so I gave myself until tonight before I went back to full win7. I’d rather not frankly!

Many thanks for the help!

Miles


(Nick Aurelius-Haddock) #16

Ok, none of that is normal behaviour, and as you have had problems with Windows, it does look like you might still have hardware issues. Have you upgrade since you installed? If not then do that immediately and re-boot the machine. You do that with System/Administration/Update Manager.

Which browsers are you using? Firefox, Chrome and Opera all work perfectly with Ubuntu, so they should all work fine for you. Do you use a proxy? If you do have you configured that correctly, if not , then make sure you have no proxy settings set.

Let me know how you get on , and feed back. If you get really stuck , I can connect to your machine remotely and fix it. Do you have an IM account ? I use Gtalk and Yahoo.

Regards

Nick


(Miles Barrington) #17

Oh, and when shutting down, it hangs and I have to use the power button to shut it down and restart…


(Miles Barrington) #18

Having a few problems with things now. All the browsers I’ve tried are loading so slowly that it’s timing out of showing a blank page with ‘done’ showing at the bottom. To post this I had to use a windows netbook…



The system analyser does not seem to be working, with everything failing, even the ‘open a document’ test, except mouse and keyboard.



The fingerprint reader (System test says there is one but I can’t find anywhere to configure it), sound (on skype in particular), webcam and dvd player also do not work.



I don’t suppose theres a quick fix for all of this?

I tried to upload the errors to launchpad.net, and the upload gave an error too.

Still willing to persevere, but for how much longer???


(Nick Aurelius-Haddock) #19

That’s excellent news. well done. Part of the transition fun is learning all the things you do on the way. This knowledge is always worth while.

Have you installed the Virtualbox drivers in your virtual machine? They are a set of custom drivers written by virtualbox to make the perfomance better in a virtual machines, and one of them is your screen driver which could well fix that problem.

With your virtual machine up and running click on the devices menu option and then select install Guest additions. In windows you will be asked to install this program from Virtualbox, and once installed you will need to re-boot it, typical windows ;-). Once thats done, you should be able to set your screen res to what ever you like.

Regards

Nick


(Miles Barrington) #20

Progress…
I’m now on Ubuntu, with a Win7 VM running and Outlook doing it’s thing. The problem now is that the screen res when the VM is full screen does not match the resolution of the screen itself, so I’m looking at a 4:3 picture on a cinemascope screen. Makes everyone and everything look like Bob Hoskins (a fine actor, sorry Bob)
I’ve looked in to the VM full screen optionss and tried things in win7 too. do I need to find the right Win7 driver and install it through the usual windows channels? Thanks all for your helps and recommends so far, I’m feeling pretty confident to this point!
Miles