Deepl - translation of Word Doc - not able to then edit?

Having had Deepl recommended here, I was thrilled to see that I could dump a 44 page Word document into their system, so within minutes I have a French translation of our English information pack for our soon-to-arrive French guests.
Unfortunately, it looks as if I cannot edit the document, which I need to do, without paying money and joining Deepl pro. Would I be correct?

Haven’t checked that (I don’t use Word) but can’t you then copy and paste the translated text to a new Word document where you will be able to format it as required then resave it with a different name.

1 Like

This review says docs were editable even without “pro”.

Sue, you can open the document and edit with WordPad.

1 Like

Thanks Nigel. Unfortunately I don’t have wordpad on my PC. I’ll see if it’s on our ancient laptop.

No Graham. Unfortunately it won’t let me do anything.

What operating system is on your PC.

That is what is implied at least on this page:

I’d forgotten about wordpad - it’s there on modern versions of Windows but hidden.

Hold down the “windows key” and R, type wordpad into the search box that comes up.

I don’t have Word, as I said, but I created a small document in LibreOffice Writer and saved it as a docx file, imported it to DeepL and it converted fine(ish) but needed a little fiddle to get rid of the DeepL logo which was annoying (well, it is “free”!).
I found this reference to add to the one posted by @billybutcher which seems to suggest a limit of 5Mb file size - does yours exceed that limit - in which case you might need to split the task. There should be no reason after the document has been translated why you should not be able to open it in another Word instance unless, perhaps, the original is still open which might suppress the ability to edit it.
EDIT: did the conversion actually finish? if it did, it should offer you the option to open the translated document in Word, save it or some other option…

Thanks everyone for your suggestions. @billybutcher PMed me and I sent him the file and he has been able to remove the protection on it, so I can now edit it.
Thanks @billybutcher

Thanks Graham for your thoughts. Just so as you know, it was 119kb. :grin:

1 Like

That’s no size at all Sue.
Have you resolved this yet? The best way (and the way I would do it) is just to copy all the text in the document (Alt+C should do it) then paste (Alt+V) in to DeepL or right mouse actions after highlighting the text rather than trying to use the drag and drop feature.
The problem seems to be that document protection is added deliberately to any document converted by DeepL whereas simple translations are not.
After translating the text, there are two options available at the bottom of the right hand panel - copy to clipboard or Share translation - image which I have used successfully in the past without any problems.

Morning Graham, as mentioned above, @billybutcher sorted it for me and told me what to do next time. Thanks. :grin:

ah… missed that :roll_eyes:
Still, better 2 responses than none!

1 Like

Hi Sue, can you tell us what @billybutcher told you to do ? I can’t find how to remove the protection .

Sorry, @Sahar_Sarraj I can’t help you as @billybutcher did it for me. You need to have a private message conversation with him. As you can see, others suggested alternative solutions (eg copying to wordpad), are any of those of use to you?

1 Like

Import into something which can read PDFs, then save in a format which won’t preserve the security information but which will preserve most of the formatting. I use Libre Office and RTF format. It depends a bit on how tightly locked down the PDF is though.


thank you so much.

Worth looking at this: